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Disclaimer 
This document is adapted from the QGIS tutorial (Ujaval Gandhi, 2014) with modification on maps, data 
source and picture.  

The Ujaval Gandhi (2014) work licensed under a Creative Commons Attribution 4.0 International License. 
Under this license, users are allowed to use, share or modify the document in any way you seem fit and 
even make commercial use of it. User only need to give appropriate credit to the author for the original 
work. 

The source code of the book Ujaval Gandhi (2014) is available on Github at:  

https://github.com/spatialthoughts/qgis-tutorials 

Chapter 10 and 11 on image processing and classification are written from scratch and did not base on 
Ujaval Gandhi (2014).

http://creativecommons.org/licenses/by/4.0/deed.en_US


Project “Integrated planning and practices for mangrove management associated  
with agriculture and aquaculture in Myanmar - 2017P1-MYR” 

1 
 

INTRODUCTION 

QGIS is a user friendly Open Source Geographic Information System (GIS) licensed under the GNU General 
Public License. QGIS is an official project of the Open Source Geospatial Foundation (OSGeo). It runs on 
Linux, Unix, Mac OSX, Windows and Android and supports numerous vector, raster, and database formats 
and functionalities. 

QGIS aims to be a user-friendly GIS, providing common functions and features. The initial goal of the 
project was to provide a GIS data viewer. QGIS has reached the point in its evolution where it is being 
used by many for their daily GIS data-viewing needs. QGIS supports a number of raster and vector data 
formats, with new format support easily added using the plugin architecture. 

QGIS provides a continuously growing number of capabilities provided by core functions and plugins. You 
can visualize, manage, edit, analyse data, and compose printable maps. Get a first impression with a more 
detailed feature list. 

QGIS feature 

QGIS offers many common GIS functionalities provided by core features and plugins. A short summary of 
six general categories of features and plugins is presented below, followed by first insights into the 
integrated Python console. 

View data 

You can view and overlay vector and raster data in different formats and projections without conversion 
to an internal or common format. Supported formats include: 

- Spatially-enabled tables and views using PostGIS, SpatiaLite and MS SQL Spatial, Oracle Spatial, 
vector formats supported by the installed OGR library, including ESRI shapefiles, MapInfo, SDTS, 
GML and many more. See section Working with Vector Data. 

- Raster and imagery formats supported by the installed GDAL (Geospatial Data Abstraction Library) 
library, such as GeoTIFF, ERDAS IMG, ArcInfo ASCII GRID, JPEG, PNG and many more. See section 
Working with Raster Data. 

- GRASS raster and vector data from GRASS databases (location/mapset). See section GRASS GIS 
Integration. 

- Online spatial data served as OGC Web Services, including WMS, WMTS, WCS, WFS, and WFS-T. 
See section Working with OGC Data. 

Explore data and compose maps 

You can compose maps and interactively explore spatial data with a friendly GUI. The many helpful tools 
available in the GUI include: 

- QGIS browser 
- On-the-fly reprojection 
- DB Manager 
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- Map composer 
- Overview panel 
- Spatial bookmarks 
- Annotation tools 
- Identify/select features 
- Edit/view/search attributes 
- Data-defined feature labelling 
- Data-defined vector and raster symbology tools 
- Atlas map composition with graticule layers 
- North arrow scale bar and copyright label for maps 
- Support for saving and restoring projects 

Create, edit, manage and export data 

You can create, edit, manage and export vector and raster layers in several formats. QGIS offers the 
following: 

- Digitizing tools for OGR-supported formats and GRASS vector layers 
- Ability to create and edit shapefiles and GRASS vector layers 
- Georeferencer plugin to geocode images 
- GPS tools to import and export GPX format, and convert other GPS formats to GPX or 

down/upload directly to a GPS unit (On Linux, usb: has been added to list of GPS devices.) 
- Support for visualizing and editing OpenStreetMap data 
- Ability to create spatial database tables from shapefiles with DB Manager plugin 
- Improved handling of spatial database tables 
- Tools for managing vector attribute tables 
- Option to save screenshots as georeferenced images 
- DXF-Export tool with enhanced capabilities to export styles and plugins to perform CAD-like 

functions 

Analyze data 

You can perform spatial data analysis on spatial databases and other OGR- supported formats. QGIS 
currently offers vector analysis, sampling, geoprocessing, geometry and database management tools. You 
can also use the integrated GRASS tools, which include the complete GRASS functionality of more than 
400 modules. (See section GRASS GIS Integration.) Or, you can work with the Processing Plugin, which 
provides a powerful geospatial analysis framework to call native and third-party algorithms from QGIS, 
such as GDAL, SAGA, GRASS, fTools and more. (See section Introduction.) 

Publish maps on the Internet 

QGIS can be used as a WMS, WMTS, WMS-C or WFS and WFS-T client, and as a WMS, WCS or WFS server. 
(See section Working with OGC Data.) Additionally, you can publish your data on the Internet using a 
webserver with UMN MapServer or GeoServer installed. 
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Extend QGIS functionality through plugins 

QGIS can be adapted to your special needs with the extensible plugin architecture and libraries that can 
be used to create plugins. You can even create new applications with C++ or Python! 

Core plugins include: 

- Coordinate Capture (Capture mouse coordinates in different CRSs) 
- DB Manager (Exchange, edit and view layers and tables from/to databases; execute SQL queries) 
- Dxf2Shp Converter (Convert DXF files to shapefiles) 
- eVIS (Visualize events) 
- fTools (Analyze and manage vector data) 
- GDALTools (Integrate GDAL Tools into QGIS) 
- Georeferencer GDAL (Add projection information to rasters using GDAL) 
- GPS Tools (Load and import GPS data) 
- GRASS (Integrate GRASS GIS) 
- Heatmap (Generate raster heatmaps from point data) 
- Interpolation Plugin (Interpolate based on vertices of a vector layer) 
- Metasearch Catalogue Client 
- Offline Editing (Allow offline editing and synchronizing with databases) 
- Oracle Spatial GeoRaster 
- Processing (formerly SEXTANTE) 
- Raster Terrain Analysis (Analyze raster-based terrain) 
- Road Graph Plugin (Analyze a shortest-path network) 
- Spatial Query Plugin 
- Topology Checker (Find topological errors in vector layers) 
- Zonal Statistics Plugin (Calculate count, sum, and mean of a raster for each polygon of a vector 

layer) 

External Python Plugins 

QGIS offers a growing number of external Python plugins that are provided by the community. These 
plugins reside in the official Plugins Repository and can be easily installed using the Python Plugin Installer. 
See Section The Plugins Dialog. 
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1 CREATING A MAP IN QGIS 
This tutorial will teach you how to make a map of Myanmar with key element such as grid line, north 
arrow, legend, scale bar and label 

1.1 Getting the data 
We will use the Natural Earth dataset - specifically the Natural Earth Quick Start Kit that comes with 
beautifully styled global layers that can be loaded directly to QGIS. 

Download data from here: http://naciscdn.org/naturalearth/packages/Natural_Earth_quick_start.zip 

Or you can copy it from the Tutorial Folder /Data/NaturalEarth/ 

1.2 Procedure 

1.2.1 Step 1. Open QGIS 

Open QGIS. Click on File ‣ Open Project. 

 

1.2.2 Step 2. Browse the data 

Browse to the directory when you had extracted the natural earth data. You should see a file named 
Natural_Earth_quick_start_for_QGIS.qgs. This is the project file that contains styled layers in QGIS 
Document format. Click Open. 

http://naciscdn.org/naturalearth/packages/Natural_Earth_quick_start.zip
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1.2.3 Step 3. View the map data 

You would see a lot of layers in the table of content and a styled world map in the QGIS canvas. If you see 
errors displayed at the top of the canvas, click on the cross to close it. 
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1.2.4 Step 4. Zoom to Myanmar 

In this tutorial, we will make a map of Myanmar. Click the Zoom In button and draw a rectangle around 
Myanmar to zoom to the area. 

1.2.5 Step 5. Use the layer control 

You can turn off some map layers for data that we do not need for this map. Un-check the box next to 
10m_geography_marine_polys and 10m_admin_0_map_units layers. Before we make a map suitable for 
printing, we need to choose an appropriate projection. This dataset comes in Geographic Coordinate 
System (GCS) where the units are degrees. This is not appropriate for a map where you want the distances 
to be in kilometers or miles. We need to use a Projected Coordinate System that minimizes distortions for 
our region of interest and has units in meters. Universal Transverse Mercator (UTM) is a decent choice for 
a projected coordinate system. It is also global, so it’s a good default that you can rely on and choose a 
UTM zone that contains your area of interest to minimize distortions for your region. In our case, we will 
use UTM Zone 47N (EPSG: 32647). Click the CRS Status button at the bottom-right of the QGIS window. 

 

1.2.6 Enable on the fly CRS 

Check the Enable on-the-fly CRS Transformation box. Type 32647 in the Filter search box. Once you see 
the results, select WGS84 /UTM Zone 47 (EPSG:32647). Click Apply. 
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1.2.7 Step 7. Make print page 

Now we can start to assemble our map. Go to Project ‣ New Print Composer. 
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1.2.8 Map title 

You will be prompted to enter a title for the composer. You can leave it empty and click Ok. 

 

Note 

Leaving the composer name empty will assign a default name such as Composer 1. 

1.2.9 Step 9. Add map 

In the Print Composer window, click on Zoom full to display the full extent of the Layout. Now we would 
have to bring the map view that we see in the QGIS Canvas to the composer. Go to Layout ‣ Add Map. 
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1.2.10 Step 10. Draw map canvas 

Once the Add Map button is active, hold the left mouse button and drag a rectangle where you want to 
insert the map. 
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1.2.11 Step 11. Move map content 

You will see that the rectangle window will be rendered with the map from the main QGIS canvas. The 
rendered map may not be covering the full extent of our interest area. Select Layout ‣ Move item content 
to pan the map in the window and center it in the composer. 

Press Control key and Scroll mouse to adjust zooming of the map content until you get map at the desired 
view. 
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1.2.12 Set zoom level 

Let us adjust the zoom level for the given map. Click on the Item Properties tab and enter 7000000 for 
Scale value. 
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1.2.13 Lock layer style 

Now we will add a map inset that shows a zoomed in view for the Tokyo area. Before we make any changes 
to the layers in the main QGIS window, check the Lock layers for map item and Lock layer styles for map 
item boxes. This will ensure that if we turn off some layers or change their styles, this view will not change. 
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1.2.14 Zoom to Aligarh 

Switch to the main QGIS window. Use the Zoom In button to zoom to the area around Yangon. 
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1.2.15 Turn off duplicate label 

There are some duplicate labels coming from the ne_10m_populated_places layer. You can turn it off for 
this view. 
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1.2.16 Inset map 

We are now ready to add the map inset. Switch the the Print Composer window. Go to Layout ‣ Add Map. 
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1.2.17 Add inset map – step 2 

Drag a rectangle at the place where you want to add the map inset. You will now notice that we have 2 
map objects in the Print Composer. When making changes, make sure you have the correct map selected. 
Select the Map 1 object that we just added from the Items panel. Select the Item properties tab. Scroll 
down to the Frame panel and check the box next to it. You can change the color and thickness of the 
frame border so it is easy to distinguish against the map background. 
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1.2.18 Highlight the inset map area in the main map 

One neat feature of the Print Composer is that it can automatically highlight the area from the main map 
which is represented in our inset. Select the Map 0 object from the Items panel. In the Item properties 
tab, scroll down to the Overviews section. Click the Add a new overview button. 
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Select Map 1 as the Map Frame. What this is telling the Print Composer is that it must highlight our current 
object Map 0 with the extent of the map shown in the Map 1 object. 
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1.2.19 Adding grid 

Now that we have the map inset ready, we will add a grid and zebra border to the main map. Select the 
Map 0 object from the Items panel. In the Item properties tab, scroll down to the Grids section. Click the 
Add a new grid button. 
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By default, the grid lines use the same units and projections as the currently selected map projections. 
However, it is more common and useful to display grid lines in degrees. We can select a different CRS for 
the grid. Click on the change... button next to CRS. 
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In the Coordinate Reference System Selector dialog, enter 4326 in the Filter box. From the results, select 
the WGS84 EPSG:4326 as the CRS. Click OK. 
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Select the Interval values as 5 degrees in both X and Y direction. You can adjust the Offset to change where 
the grid lines appear. 
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Scroll down to the Grid frame section and select a frame style that suits your taste. Also check the Draw 
coordinates box. 
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Adjust the Distance to map frame till the coordinates are legible. Change the Coordinate precision to 1 so 
the coordinates are displayed only upto the first decimal 
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1.2.20 Adding North arrow 

Now we will add a North Arrow to the map. The Print Composer comes with a nice collection of map-
related images - including many types of North Arrows. Click Layout ‣ Add Image. 
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Holding your left mouse button, draw a rectangle on the top-right corner of the map canvas. On the right-
hand panel, click on the Item Properties tab and expand the Search directories section and select the 
North Arrow image of your liking. 
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Now we will add a scale bar. Click on Layout ‣ Add Scalebar. 
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Click on the layout where you want the scalebar to appear. In the Item Properties tab, make sure you 
have chosen the correct map element for which to display the scalebar. Choose the Style that fit your 
requirement. In the Segments panel, you can adjust the number of segments and their size. 

1.2.21 Add label 

It is time to label our map. Click on Layout ‣ Add Label. 
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Click on the map and draw a box where the label should be. In the Item Properties tab, expand 
the Label section and enter the text as shown below. We can enter the text as HTML as well. Check the 
box Render as Html so the composer will interpret the HTML tags. 

<div align=center> 

<h1>Map of Myanmar</h1> 

</div> 



Project “Integrated planning and practices for mangrove management associated  
with agriculture and aquaculture in Myanmar - 2017P1-MYR” 

30 
 

 
Similarly add another label to add the data and software credits. 

 
Once you are satisfied with the map, you can export it as Image, PDF or SVG. For this tutorial, let’s export 

it as an image. ClickComposer ‣ Export as Image. 
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Save the image in the format of your liking. Below is the exported PNG image. 
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2 WORKING WITH ATTRIBUTE DATA 
GIS data has two parts - features and attributes. Attributes are structured data about each feature. This 
tutorial shows how to view the attributes and do basic queries on them in QGIS. 

2.1 Overview of the task 
The dataset for this tutorial contains information about populated places of the world. The task is to query 
and find all the capital cities in the world that have a population greater than 1,000,000. 

Other skills you will learn 

Select features from a layer using expressions. 

Deselect features from a layer using the Attributes toolbar. 

Using Query Builder to show a subset of features from a layer. 

Getting the data 

Natural Earth has a nice Populated Places dataset. Download the simple (less columns) dataset 

For convenience, you may directly download a copy of datasets from the link below: 

ne_10m_populated_places_simple.zip 

Data Source [NATURALEARTH] 

2.2 Procedure 

2.2.1 Step 1.  Adding data 

Once you have downloaded the data, open QGIS. Go to Layer ‣ Add Layer ‣ Add Vector Layer. 

http://www.qgistutorials.com/downloads/ne_10m_populated_places_simple.zip
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Click on Browse and navigate to the folder where you downloaded the data. 

 

Locate the downloaded zip file ne_10m_populated_places_simple.zip. You do not need to unzip the file. 
QGIS has the ability to read zip files directly. Select the file and click Open. 
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The selected layer will now be loaded in QGIS and you will see many points representing the populated 
places of the world. 
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2.2.2 Viewing attribute 

Right-click the layer and select Open Attribute Table. 
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Explore the various attributes and their values. 
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We are interested in the population of each feature, so pop_max is the field we are looking for. You can 
click twice on the field header to sort the column in descending order. 
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2.2.3 Query the data 

Now we are ready to perform our query on these attributes. QGIS uses SQL-like expressions to perform 
queries. Click Select features using an expression. 
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In the Select By Expression window, expand the Fields and Values section and double-click the pop_max 
label. You will notice that it is added to the expression section at the bottom. If you aren’t sure about the 
field values, you can click the Load all unique values to see what the attribute values are present in the 
dataset. For this exercise, we are looking to find all features that have a population greater than 1,000,000. 
So complete the expression as below and click Select. 

"pop_max" > 1000000 
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Click on Close and return to the main QGIS window. You will notice that a subset of points is now rendered 
in yellow. This is the result of our query and you are seeing all places from the dataset that have the 
pop_max attribute value greater than 1,000,000 
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The goal for this exercise is to find the places that are country capitals. The field containing this data is 
adm0cap. The value 1 indicates that the place is a capital. We can add this criteria to our previous 
expression using the and operator. Let’s refine our query to select only those places which are capitals. 
Click on the Select feature using an expression button in the attribute table and enter the expression as 
below and click Select and then Close. 

"pop_max" > 1000000 and "adm0cap" = 1 
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Return to the main QGIS window. Now you will see a smaller subset of the points selected. This is the 
result of the second query and shows all places from the dataset that are country capitals as well as have 
population greater than 1,000,000. If we wanted to do some further analysis on this subset of data, we 
can make this selection persistent. Right-click the ne_10m_populated_places_simple layer and select 
Properties. 
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In the General tab, scroll down to the Feature subset section. Click Query Builder. 
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Enter the same expression you had entered earlier and click OK. 

"pop_max" > 1000000 and "adm0cap" = 1 
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Back in the main QGIS window, you will see rest of the points disappear. You may now perform any other 
analysis on this layer and only the features that match our expression will be used. You will notice that 
the points still appear in yellow. This is because they are still selected. Find the Deselect Features from All 
Layers button under the Attributes toolbar and click on it. 
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You will see that the points are now de-selected and rendered in their original color. 
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3 WORKING WITH SPREADSHEET AND CSV DATA 
Many times the GIS data comes in a table or an Excel spreadsheet. Also, if you have a list lat/long 
coordinates, you can easily import this data in your GIS project. 

3.1 Overview of the task 
We will be importing a text file of earthquake data to QGIS. 

Get the data 

NOAA’s National Geophysical Data Center produces a great dataset of all significant earthquakes since 
2150 BC.  

Download Significant Earthquake Database text file. 

Data Source [NGDC] 

3.2 Procedure 

3.2.1 Examine tabular data 

Examine your tabular data source. To import this data to QGIS, you will have to save it as a text file and 
need at least 2 columns which contain the X and Y coordinates. If you have a spreadsheet, use Save 
As function in your program to save it as a Tab Delimited File or a Comma Separated Values (CSV) file. 
Once you have the data exported this way, you can open it in a text editor such as Notepad to view the 
contents. In case of the Significant Earthquake Database, the data already comes as a text file which 
contains latitude and longitude of the earthquake centers along with other related attributes. You will see 
that each field is separated by a TAB. 

http://www.ngdc.noaa.gov/nndc/struts/results?type_0=Exact&query_0=$ID&t=101650&s=13&d=189&dfn=signif.txt
http://www.qgistutorials.com/en/docs/credits.html#ngdc
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3.2.2 Import tabular data into QGIS 

Open QGIS. Click on Layers ‣ Add Delimited Text Layer. 
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In the Create a Layer from a Delimited Text File dialog, click on Browse and specify the path to the text 
file you downloaded. In the File format section, select Custom delimiters and check Tab. The Geometry 
definition secction will be auto-populated if it finds a suitable X and Y coordinate fields. In our case they 
are LONGITUDE and LATITUDE. You may change it if the import selects the wrong fields. Click OK. 

Note 

It is easy to confuse X and Y coordinates. Latitude specifies the north-south position of a point and 
hence it is a Y coordinate. Similarly Longitude specifies the east-west position of a point and it is 
a X coordinate. 
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You may see some errors displayed in the next dialog. The errors in this file are mainly due to missing X or 
Y fields. You may examine these errors and fix the problems in your source file. For this tutorial, you may 
ignore these errors. 
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Next, a Coordinate Reference System Selector will ask you to select a coordinate reference system. 
Since the earthquake coordinates are in latitudes and longitudes, you should select WGS 84. Click OK. 
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You will now see that the data will be imported and displayed in the QGIS canvas. 
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4 USING PLUG-IN 
Plugins in QGIS add useful features to the software. Plugins are written by QGIS developers and other 
independent users who want to extend the core functionality of the software. These plugins are made 
available in QGIS for all the users. 

4.1 Overview of the task 
In this tutorial, you will learn how to enable Core Plugins as well as download and install External Plugins. 
You will also learn how to locate the plugin from the QGIS menu once they are installed. 

4.2 Procedure 

4.2.1 Core Plugins 
Core plugins are already part of the standard QGIS installation. To use these, you just need to 
enable them. 

1. Open QGIS. Click on Plugins ‣ Manage and Install P lugins... . to open the Plugin 
Manager dialog. 
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2. Even if this is your first time using QGIS, you will see a lot of plugins listed under 
the Installed tab. This is because they are Core Plugins and were installed during QGIS 
installation. 

 

3. Let’s enable one of the plugins. Check on the checkbox next to Spatial Query Plugin. This 
will enable the plugin and you will be able to use it. One thing to note is that plugins have 
the ability to insert menu items at various locations and create new panels and toolbars. 
Sometimes it is difficult to know how to find the newly enabled tools. Once clue is to look in 
the plugin discription. Here the description says Category: Vector. That indicates that the 
plugin would be found under the Vector menu once enabled. Click Close. 
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4. Now that the Spatial Query Plugin is enabled, you can go to the Vector ‣ Spatial Query  to 
use the functionality added by the plugin. 
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4.2.2 External Plugins 
External plugins are available in the QGIS Plugins Repository and need to be installed by the users 
before using them. An easy way to browse and install these plugins is by using the Plugin 
Manager tool. 

1. Open QGIS. Click on Plugins ‣ Manage and Install Plugins.... to open the Plugin 
Manager dialog. 

http://plugins.qgis.org/
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2. Click on Get more tab. Here you will see a list of plugins listed. 
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3. For this tutorial, let’s find and install a plugin called ‘QuickQKT’. As you start typing qui in 
the search box, you will see the search results below. Click on the QuickWKT. Next, click 
on Install plugin button to install it. 
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4. Once the plugin is downloaded and installed, you will see a confirmation dialog. 

 

5. If you noticed, there was no mention of the plugin category in the description. That makes it 
hard to determine how to access the newly installed plugin. Most external plugins are 
installed under the Plugins menu itself in QGIS. Click on Plugins ‣ QuickWKT  and you will 
see the newly installed plugin. Usually, external plugins also install a button in 
the Plugins toolbar also. You may also use that button to access the plugin. 
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4.2.3 Experimental Plugins 
Now you know how to install and find an External Plugin in QGIS. Let’s explore some advanced 
options. Sometimes you are looking for a specific plugin, but cannot find it in the Get more tab. It 
maybe because the plugin is marked Experimental. Here is how to install experimental plugins. 

1. Open Plugin Manager by Plugins ‣ Manage and Install P lugins... . Click on the Settings tab. 
You will see an option called Show also experimental plugins. Click the checkbox next to it, 
to enable it. 
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2. You will see a new tab called New. The newly enabled experimental plugins will show up 
here. 

Note 
The New tab will appear only temporarily once you enable the experimental plugins. The next time 
you open Plugin Manager, the experimental plugins will show alongside regular plugins in the Get 
more tab. 
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3. Let’s install a plugin called TimeManager. Click on the plugin name and then Click Install. 
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4. Now when you come back to the main QGIS window, you will see a new Panel at the bottom 
of the canvas. This panel is created by the TimeManager plugin. This is yet another way of 
plugins to add useful functionality to the user interface. 
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5. You can enable/disable this panel from View ‣ Panels ‣  Time Manager . 
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5 Searching and Downloading OpenStreetMap Data 
Getting high quality data is essential for any GIS task. One great resource for free and openly 
licensed data is OpenStreetMap(OSM) . The OSM database consits of streets, local data as well as 
building polygons. Getting access to OSM data in a GIS format is integrated in QGIS. This tutorial 
explains the process for searching, downloading and using OSM data in QGIS. 

5.1 Overview of the task 
Search for Naypyidaw in OSM database, browse and select a part of the city, and extract all pub 
locations as a shapefile. 

5.2 Procedure 

1. We will use 2 plugins to accomplish the task. Make sure you have installed OSM Place 
Search and OpenLayers plugins. See Using Plugins for instructions on downloading 
plugins. 

 

2. The OSM Place Search plugin will install itself as a Panel in QGIS. You will see a new panel 
titled OSM place search... in QGIS. 

http://www.openstreetmap.org/
http://www.qgistutorials.com/en/docs/using_plugins.html
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3. The OpenLayers plugin is installed under the Plugin menu. This plugin allows you to access 
basemaps from various providers in QGIS. Let’s load the OpenStreetMap basemap in QGIS 
by going to Plugins ‣ OpenLayers plugin ‣  Add OpenS treetMap layer. 
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4. You will see a world map loaded in QGIS. 

Note 
If you do not see any data - make sure you are online - as the basemap tiles are fetched from the 
internet. You can also use the Pantool to move the map canvas slightly, which will trigger a refresh 
of the basemap. 
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5. Now, let’s search for Naypyidaw. Type the query in the Name contains... box in the OSM 
Place Search panel. You can hover over the results and the appropriate place will be 
highlighted on the map. Select the first result - which the city of Naypyidaw - and click 
the Zoom button. 
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6. You will see the base layer move and center around the city of Naypyidaw. You can use 
the Zoom tool to zoom and select the exact area of your interest. For this tutorial, you can 
zoom in the center of the city as shown. 

 

7. Now we can download the data displayed on the map canvas. Go to Vector ‣ 
OpenStreetMap ‣ Downlod data . 
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8. In the Download OpenStreetMap data dialog, choose From map canvas as the Extent. 
Choose the path and name the output file as Naypidaw.osm. 

 

9. The downloaded file with the .osm extension is an text file in the OSM XML format. We first 
need to convert it into a suitable format that is easy to consume in QGIS. Go to Vector ‣ 
OpenStreetMap ‣ Import topology from XML . 

http://wiki.openstreetmap.org/wiki/OSM_XML
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Note 
Now that we do not need the OSM Place Search functionality, you can click the close button to 
remove it from the main window. If you need to use it again, you can enable it from View ‣ 
Panels ‣ OSM place searc h... (Windows) or Settings ‣ Panels ‣  OSM place 
search... (Linux). 

 

10. Choose the downloaded Naypidaw.osm as the Input XML file. Name the Output SpatiaLite DB 
file as Naypidaw.osm.db. Make sure the Create connection (SpatiaLite) after import button is 
checked. 
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11. Now the last step. We need to create SpatialLite geometry layers that can be viewed and 
analyzed in QGIS. This is done using Vector ‣ OpenStreetMap ‣  Export topology to 
SpatialLite. 

 

12. The Naypyidaw.osm.db file contains all feature types in the OSM database - Points, Lines and 
Polygons. GIS layers typically contain only one type of feature, so you need to choose one. 
Since we are interested in point locations of pubs, here you need to choose Point (nodes) as 
the Export type. You would choose Polylines (open ways) if you wanted to get the road 
network. Name the Output layer name as Naypyidaw_points. GIS data has 2 parts to it - 
location and attributes. We are also interested in the name of the pub - not just its location, 
so we need to export that information as well. Click on Load from DB under Exported 
tags section. This will fetch all attributes from the Naypyidaw.osm.db file. 
Check name and amenity tags. See OSM Tags to learn more about what each attribute 
means. Make sure the Load into canvas when finished is checked, and click OK. 

http://wiki.openstreetmap.org/wiki/Tags
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13. You will see a new point layer named Naypyidaw_points loaded in QGIS. Note that this 
contains ALL points in the OSM database for the viewport. Since we are interested only in 
pubs, we need to write a query to select only those. Right click on Naypyidaw_pointslayer 
and select Open Attribute Table. 
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14. You will note that some features have the attribute value of restaurant listed under 
the amenity column. Click on Select features using an expression button. 
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15. Enter the expression “amenity” = ‘restaurants’ and click Select.  

 

16. Back in the QGIS Canvas, you will see some points highlighted in yellow. These are the 
result of our query. Right-click the Naypyidaw_points layer and choose Save Selection As.... 
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17. In the Save vector layer as... dialog, enter the name of the output file 
as Naypyidaw_pubs.shp. Leave all other options as they are and make sure the Add saved 
file to map option is checked. Click OK. 



Project “Integrated planning and practices for mangrove management associated  
with agriculture and aquaculture in Myanmar - 2017P1-MYR” 

81 
 

 

18. You will see a new layer named Naypyidaw_pubs in the QGIS canvas. Uncheck the Naypyidaw 
_points layer as we don’t need that anymore. 
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19. The extraction of the pubs shapefile layer is now complete. You can use the Identify tool to 
click on any of the point as see its attributes. 
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6 Basic Vector Styling 
To create a map, one has to style the GIS data and present it in a form that is visually informative. 
There are a large number of options available in QGIS to apply different types of symbology to the 
underlying data. In this tutorial, we will explore some basics of styling. 

6.1 Overview of the task 
We will style a vector layer to show life expectancy in different countries of the world. 

Other skills you will learn 

- View the attribute table of a vector layer. 

6.2 Get the data 
The data we will use is from Center for Sustainability and the Global Environment (SAGE) at the 
University of Wisconsin-Madison. 

You can download the Life Expectancy GIS Grid data from the human impact dataset. 

For convenience, you may directly download a copy of the dataset from the link below: 

lifeexpectancy.zip 

Data Source [SAGE] 

6.2.1 Procedure 

1. Open QGIS and go to Layer ‣ Add Vector Layer.. . 

http://nelson.wisc.edu/sage/index.php
http://nelson.wisc.edu/sage/data-and-models/atlas/data.php?incdataset=Life%20Expectancy
http://www.qgistutorials.com/downloads/lifeexpectancy.zip
http://www.qgistutorials.com/en/docs/credits.html#sage
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2. Browse to the downloaded lifeexpectancy.zip file and click Open. 
Select newsweek_data.shp and click Open. Next you will be prompted for choosing the CRS. 
Select WGS84 EPSG:4326 as the Coordinate Reference System (CRS). 
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3. The shapefile contained within the zip file is now loaded and you can see the default style 
applied to it. 
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4. Right click on the layer name and select Open Attribute Table. 
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5. Explore the different attributes. To style a layer, we must pick an attribute or a column that 
would represent the map we are trying to create. Since we want to create a layer represting 
life expectancy, i.e. the average age till a person lives in a country, the field LIFEXPCT is 
the attribute we want to use in styling. 
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6. Close the attribute table. Right click on the layer again and choose Properties. 
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7. The various styling options are located in the Style tab of the Properties dialog. Clicking on 
the drop-down button inthe Style dialiog, you will see there are five options available 
- Single Symbol, Categorized, Graduated, Rule Based and Point displacement. We will 
explore the first three in this tutorial. 
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8. Select Single Symbol. This option allows you to choose a single style that will be applied to 
all the features in the layer. Since this is a polygon dataset, you have two basic choices. You 
can fill the polygon, or you can style with only outline. You can choose the dotted pattern fill 
and click OK. 
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9. You will see a new style applied to the layer with the fill pattern you chose. 
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10. You will see that this Single Symbol style isn’t useful in communicating the life expectancy 
data we are trying to map. Let us explore another styling option. Right-click the layer again 
and choose Properties. This time choose Categorized from the Styletab. Categorized 
means the features in the layer will be shown in different shades of a color based on unique 
values in an attribute field. Choose LIFEXPCT value as the Column. Choose a color 
ramp of your choice and click Classify at the bottom. Click OK. 
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11. You will see different countries appearing in shades of blue. Lighter shades meaning lower 
life expectancy and darker shades meaning higher life expectancy. This representation of the 
data is more useful and clearly show how life expectancy in developed countries vs. 
developing countries. This would be the type of style we set out to create. 
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12. Let us explore the Graduated symbology type in the Style dialog now. Graduated 
symbology type allows you to break down the data in a column in unique classes and choose 
a different style for each of the classes. We can think of classifying our life expectancy data 
into 3 classes, LOW, MEDIUM and HIGH. Choose LIFEXPCT as the Column and choose 3 as 
the classes. You will see there are many Mode optionsa vailable. Let us see the logic behind 
each of these modes. There are 5 modes available. Equal Interval, Quantile, Natural 
Breaks (Jenks), Standard Deviation and Pretty Breaks. These modes use different 
statistical algorithms to break down the data into separate classes. 

o Equal Interval: As the name suggests, this method will will create classes which are 
at the same size. If our data ranges from 0-100 and we want 10 classes, this method 
would create a class from 0-10, 10-20, 20-30 and so on , keeping each class the 
same size of 10 units. 

o Quantile - This method will decide the classes such that number of values in each 
class are the same. If there are 100 values and we want 4 classes, quantile method 
will decide the classes such that each class will have 25 values. 

o Natural Breaks (Jenks) - This algorithm tries to find natural groupings of data to 
create classes. The resulting classes will be such that there will be maximum 
variance between individual classes and least variance within each class. 

o Standard Deviation - This method will calculate the mean of the data, and create 
classes based on standard deviation from the mean. 
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o Pretty Breaks - This is based on the statistical package R’s pretty algorithm. It is a bit 
complex, but the pretty in the name means it creates class boundaries that are 
round numbers. 

To keep things simple, let’s use the Quantile method. Click Classify at the bottom and you 
will see 3 classes show up with their corresponding values. Click OK. 

Note 
For an attribute to be used in Graduated style, it must be a numeric field. Integer and Real values 
are fine, but if the attribute field type is String, it cannot be used with this styling option. 

 

13. You will see a map showing countries in either of 3 colors representing average life 
expectancy in the country. 
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14. Now go back to the Style dialog by right clicking the layer and choosing Properties. There 
are some more styling options available. You can click on the Symbol for each of the classes 
and choose a different style. We will choose Red, Yellow and Green fill colors to indicate low, 
medium and high life expectancy. 
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15. In the Symbol Selector dialog, click on Color selector. 
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16. Click on a color fom the Select Color dialog. 
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17. Back in the Layer Properties dialog, you can double-click on the Label column next to each 
value and enter the text that you want to display. Similarly, you may double-click on 
the Value column to edit the selected ranges. Click OK once you are satisfied with the 
classes. 
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18. This style definitely conveys a lot more useful map than the previous two attempts. There 
are clearly marked class names and colors to represent our interpretation of the life 
expectancy values. 
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7 Basic Raster Styling and Analysis 
A lot of scientific observations and research produces raster datasets. Rasters are essentially grids of 
pixels that have a specific value assigned to them. By doing mathematical operations on these 
values, one can do some interesting analysis. QGIS has some basic analysis capabilities built-in 
via Raster Calculator. In this tutorial, we will explore basics on using Raster Calculator and options 
available for styling rasters. 

7.1 Overview of the task 
We will use population density grid data to find and visualize areas of the world that have seen 
dramatic population density change between year 1990 and 2000. 

7.1.1 Other skills you will learn 

- Selecting and loading multiple datasets in a single step in QGIS. 

7.2 Get the data 
We will use the Gridded Population of the World (GPW) v3 dataset from Columbia University. 
Specifically, we need the Population Density Grid for the entire globe in ASCII format and for the 
year 1990 and 2000. 

Here is how to search and download the relevant data. 

1. Go to the Population Density Grid, v3 download page. Select the Data Attributes as .ascii 
format, 1° resolution and 1990 year. Click Download. At this point, you may create a free 
account and login, or use the Guest Download button at the bottom to immediately 
download the data. Repeat the process for 2000 year data. 

http://sedac.ciesin.columbia.edu/data/collection/gpw-v3
http://sedac.ciesin.columbia.edu/data/set/gpw-v3-population-density/data-download
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You will now have 2 zip files downloaded. 

For convenience, you may directly download a copy of the datasets from the links below: 

gl_gpwv3_pdens_90_ascii_one.zip 

gl_gpwv3_pdens_00_ascii_one.zip 

Data Source [GPW3] 

7.3 Procedure 

2. Open QGIS and go to Layer ‣ Add Raster Layer... 

http://www.qgistutorials.com/downloads/gl_gpwv3_pdens_90_ascii_one.zip
http://www.qgistutorials.com/downloads/gl_gpwv3_pdens_00_ascii_one.zip
http://www.qgistutorials.com/en/docs/credits.html#gpw3
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3. Locate the downloaded zip files. Hold down the Ctrl key and click on both the zip files to 
select them. This way you are able to load both the files in a single step. 
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4. Each zip file contain 2 grid files. The a in the filename suggests that the population counts 
were adjusted to match the UN totals. We will use the adjusted grids for this tutorial. 
Select glds00ag60.asc as the layer to add. Click OK. 

 

5. The layer doesn’t have a CRS defined, and since the grids are in lat/long, 
choose EPSG:4326 as the coordinate reference system. 
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6. Since we selected both the zip files, you will see similar dialogs once again. Repeat the 
process and select glds90ag60.asc grid as the layer to add. 
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7. Once again, choose EPSG:4326 as the CRS. 
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8. Now you will see both the rasters loaded in QGIS. The raster is rendered as in grayscale, 
where darker pixels indicate lower values and lighter pixels indicate higher values. 
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9. Each pixel in the raster has a value assigned. This value is the population density for that 
grid. Click on Identify Features button to select the tool and click anywhere on the raster to 
see the value of that pixel. 
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10. To better visualize the pattern of population density, we would need to style it. Right-click on 
the layer name and select Properties. You can also double-click on the layer name in the 
TOC to bring up the Layer Properties dialog. 
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11. Under the Style tab, change the Render type to Singleband pseudocolor. Next, 
click Classify under Generate a new color map. You will see 5 new color values created. 
Click OK. 
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12. Back in the QGIS Canvas, you will see a heatmap-like rendering of the raster. Repeat the 
same process for the other raster as well. 
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13. For our analysis, we would like to find areas with largest population change between 1990 
and 2000. The way to accomplish this is by finding the difference between each grid’s pixel 
value in both the layers. Select Raster ‣ Raster calculator . 
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14. In the Raster bands section, you can select the layer by double-clicking on them. The bands 
are named after the raster name followed by @ and band number. Since each of our rasters 
have only 1 band, you will see only 1 entry per raster. The raster calculator can apply 
mathematical operations on the raster pixels. In this case we want to enter a simple formula 
to subtract the 1990 population density from 2000. Enter glds00ag60@1 - glds90ag60@1 as 
the formula. Name your output layer aspop_density_change_2000_1990.tif and check the 
box next to Add result to project. Click OK. 
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15. Once the operation is complete, you will see the new layer load in QGIS. 
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16. This grayscale visualization is useful, but we can create a much more informative output. 
Right-click on the pop_density_change_2000_1990 layer and select Properties. 
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17. We want to style the layer so pixel values in certain ranges get the same color. Before we 
dive in to that, go to the Metadata tab and look at the properties of the raster. Note the 
minimum and maximum values of this layer. 
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18. Now go to the Style tab. Select Singleband pseudocolor as the Render type under Band 
Rendering. Set the Color interpolation toDiscrete. Click the Add entry button 4 times to 
create 4 unique classes. Click on an entry to change the values. The way color map works is 
that all values lower than the value entered will be given the color of that entry. Since the 
minmum value in our raster is just above -2000, we choose -2000 as the first entry. This will 
be for the No Data values. Enter the values and Labels for other entries as below and 
click OK. 
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19. Now you will see a much more powerful visualization where you can see areas which has 
seen positive and negative population density changes. Click on Zoom In button and draw a 
rectangle around Europe to explore the region in more detail. 
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20. Select the Identify tool and click on the Red and Blue regions to verify that your styling rules 
worked as intended. 
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21. Now let’s take this analysis one-step further and find areas with only negative population 
density change. Open Raster ‣ Raster calculator . 
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22. Enter the expression as shown below What this expression will do is set the value of the 
pixel to 1 is if matches the expression and 0 if it doesn’t. So we will get a raster with pixel 
value of 1 where there was negative change and 0 where there wasn’t. Name the output 
layer as negative_pop_change_2000_1990 and check the box next to Add result to project. 
Click OK. 

pop_density_change_2000_1990@1 < -10 
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23. Once the new layer is loaded, right-click on it and select Properties. In 
the Transparency tab, add 0 as the Additional no data value. This setting will make the 
pixels with 0 values also transparent. Click OK. 
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24. Now you will see the areas of negative population density change as gray pixels. 
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8 Working with Terrain Data 
Terrain or elevation data is useful for many GIS Analysis and it is often used in maps. QGIS has 
good terrain processing capabilities built-in. In this tutorial, we will work through the steps to 
generate various products from elevation data such as contours, hillshade etc. 

8.1 Overview of the task 
The task is to create contours and hillshade map for area around Mountain Hkakabo Razi. 

8.1.1 Other skills you will learn 

- Searching and downloading freely available terrain data. 
- Exporting a vector layer as KML and viewing it in Google Earth. 

8.2 Get the data 
We will be working with GMTED2010 dataset from USGS. This data can be downloaded from 
the USGS Earthexplorer site. GMTED (Global Multi-resolution Terrain Elevation Data) is a global 
terrain dataset that is the newer version of GTOPO30 dataset. 

Here is how to search and download the revelant data from USGS Earthexplorer. 

1. Go to the USGS Earthexplorer . In the Search Criteria tab, search for the place 
name Hkakabo Razi. Click on the result to select the location. 

 
 

2. In the Data Sets tab, expand the Digital Elevation group, and check GMTED2010. 

http://earthexplorer.usgs.gov/
http://eros.usgs.gov/#/Find_Data/Products_and_Data_Available/GMTED2010
http://earthexplorer.usgs.gov/
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3. You can now skip to the Results tab and see the part of the dataset intersecting your search 
criteria. Click the Download Options button. You will have to log in to the site at this point. 
You can create a free account if you do not have one. 

 

4. Select the 30 ARC SEC option and click Select Download Option. 
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You will now have a file named GMTED2010N10E060_300.zip. Elevation data is distributed in 
various raster formats such as ASC, BIL, GeoTiff etc. QGIS supports a wide variety of raster 
formats via the GDAL library. The GMTED data comes as GeoTiff files which are contained in this zip 
archive. 

For convenience, you can download a copy of the data directly from below. 

GMTED2010N10E060_300.zip 

Data Source: [GMTED2010] 

8.3 Procedure 

5. Open Layer ‣ Add Raster Layer  and browse to the downloaded zip file. 

 

http://www.gdal.org/formats_list.html
http://www.gdal.org/formats_list.html
http://www.qgistutorials.com/downloads/GMTED2010N10E060_300.zip
http://www.qgistutorials.com/en/docs/credits.html#gmted2010
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6. There are many different files generated from different algorithms. For this tutorial, we will 
use the file named 10n060e_20101117_gmted_mea300.tif. 

 

7. You will see the terrain data rendered in the QGIS Canvas. Each pixel in the terrain raster 
represents the average elevation in meters at that location. The dark pixels represent areas 
with low altitude and lighter pixels represent areas with high altitude. 

 

8. Zoom to the area around Hkakabo Razi. 
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9. We will now crop the raster to this area of interest. Select the Clipper tool from Raster ‣ 
Extraction ‣ Clipper . 

Note 
The Raster menu in QGIS comes from a core plugin called GdalTools. If you do not see 
the Raster menu, enable the GdalTools plugin from Plugins ‣ Manage and install plugins ‣  
Installed. See Using Plugins for more details. 

http://www.qgistutorials.com/en/docs/using_plugins.html
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10. In the Clipper window, name your output file as everest_gmted30.tif. Select the Clipping 
mode as Extent. 



Project “Integrated planning and practices for mangrove management associated  
with agriculture and aquaculture in Myanmar - 2017P1-MYR” 

131 
 

 

11. Keep the Clipper window open and switch to the main QGIS window. Hold your left mouse 
button and draw a rectangle covering the full canvas. 
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12. Now back in the Clipper window, you will see the coordinates auto-populated from your 
selection. Make sure the Load into canvas when finished option is checked, and click OK. 
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13. Once the process finishes, you will see a new layer loaded in QGIS. This layer covers only 
the area around Mountain Hkakabo Razi. Now we are ready to generate contours. Select the 
contour tool from Raster ‣ Extraction ‣  Contour . 
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14. In the Contour dialog, select everest_gmted30 as the Input file. Name the Output file for 
contour lines as h_countours.shp. We will generate contour lines for 100m intervals, so put 
100 as the Interval between contour lines. Also check the Attribute name option so elevation 
value will be recorded as attribute of each contour line. Click OK. 
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15. Once the processing is complete, you will see contour lines loaded into the canvas. Each line 
in this layer represents a particular elevation. All points along a countour line in the 
underlying raster would be at the same elevation. The closer the lines, the steeper the slope. 
Let’s inspect the contours a bit more. Right click on the contours layer and choose Open 
Attribute Table. 
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16. You will see that each line feature has an attribute named ELEV. This is the height in metres 
that each line represents. Click on the column header a couple of times to sort the values in 
descending order. Here you will find the line representing the highest elevation in our data. 
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17. Select the top row, and click on the Zoom to selection button. 
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18. Switch to the main QGIS window. You will see the selected contour line highlighted in 
yellow. This is the area of the highest elevation in our dataset. 
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19. Now let us create a hillshade map from the raster. Select Raster ‣ Analysis ‣  DEM 
(Terrain Models). 
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20. In the DEM (Terrain Models) dialog, choose mountain.tif as the Input file. Name the Output 
file as mountain_hillshade.tif. Choose Hillshade as the Mode. Leave all other options as is. 
Make sure the Load into canvas when finished option is checked, and click OK. 
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21. Rright click on the Mountain_hillshade layer and choose Zoom to Layer Extent. 
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22. Now you will see the full extent of the hillshade raster. 
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23. You can also visualize your contour layer and verify your analysis by exporting the contours 
layer as KML and viewing it in Google Earth. Right click on the contours layer, select Save 
as... 

 

24. Select Keyhole Markup Language [KML] as the Format. Name your output 
as contours.kml and click OK. 
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25. Browse to the output file on your disk and double-click on it to open Google Earth. 
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9 Digitizing Map Data 
Digitizing is one of the most common tasks that a GIS Specialist has to do. Often a large amount 
of GIS time is spent in digitizing raster data to create vector layers that you use in your analysis. 
QGIS has powerful on-screen digitizing and editing capabilities that we will explore in this tutorial. 

9.1 Overview of the task 
We will use a raster topographic map and create several vector layers representing features around 
a park. 

9.2 Other skills you will learn 
- Building pyramids for large raster datasets to speed up zoom and pan operations. 
- Working with a Spatialite database. 

9.3 Get the data 
Land Information New Zealand (LINZ) provides raster topographic maps at 1:50,000 scale for the 
New Zealand mainland and Chatham Islands. 

Download the GeoTIFF Image file from the Christchurch Topo50 map download page. 

For convenience, you may directly download a copy of the dataset from the link below: 

BX24_GeoTifv1-02-clip.tif 

Data Source [LINZ] 

9.4 Procedure 

1. Go to Layer ‣ Add Raster Layer . Locate the downloaded BX24_GeoTifv1-02.tif and 
click Open. 

http://www.linz.govt.nz/
http://topo.linz.govt.nz/Topo50_raster_images/GeoTIFFTopo50/BX24_GeoTifv1-02.tif
http://www.linz.govt.nz/topography/topo-maps/map-chooser/christchurch/christchurch#digitalfile
http://www.qgistutorials.com/downloads/BX24_GeoTifv1-02-clip.tif
http://www.qgistutorials.com/en/docs/credits.html#linz
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2. This is a large raster file and you may notice that when you zoom or pan around the map, 
the map takes a little time to render the image. QGIS offers a simple solution to make 
rasters load much faster by using Image Pyramids. QGIS creates pre-rendered tiles at 
different resolutions and these are presented to you instead of the full raster. This makes 
map navigation snappy and responsive. Right-click the BX24_GeoTifv1-02 layer and 
choose Properties. 
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3. Choose the Pyramids tab. Hold the Ctrl key and select all the resolutios offered in 
the Resolutions panel. Leave other options to defaults and click Build pyramids. Once the 
process finishes, click OK. 
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4. Back in the main QGIS window, use the Zoom tool to locate Hagley Park area in 
Christchurch. This is the park that we will be digitizing. 
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5. Before we start, we need to set default Digitizing Options. Go to Settings ‣ Options... . 
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6. Select the Digitizing tab in the Options dialog. Set the Default snap mode to To vertex and 
segment. This will allow you to snap to the nearest vertex or line segment. I also prefer to 
set the Default snapping tolerance and Search radius for vertex edits in pixels instead of 
map units. This will ensure that the snapping distance remains constant regardless of zoom 
level. Depending on your computer screen resolution, you may choose an appropriate value. 
Click OK. 
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7. Now we are ready to start digitizing. We will first create a roads layer and digitize the roads 
around the park area. Select Layer ‣ New ‣  New Spatialite Layer... . You may also choose to 
create a New Shapefile Layer... instead if you prefer. Spatialite is an open database format 
similar to ESRI’s geodatabase format. Spatialite database is contained within a single file on 
your hard drive and can contain diferent types of spatial (point, line, polygon) as well as 
non-spatial layers. This makes is much easier to move it around instead of a bunch of 
shapefiles. In this tutorial, we are creating a couple of polygon layers and a line layer, so a 
Spatialite database will be better suited. You can always load a spatialite layer and save it as 
a shapefile or any other format you want. 
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8. In the New Spatialite Layer dialog, click the ... button and save a new spatialite database 
named nztopo.sqlite. Choose the Layer name as Roads and select Line as the Type. The 
base topographic map is in the EPSG:2193 - NZGD 2000 CRS, so we can select the same for 
our roads layer. Check the Create an autoincrementing primary key box. This will create a 
field called pkuid in the attribute table and assign a unique numeric id automatically to each 
feature. When creating a GIS layer, you must decide on the attributes that each feature will 
have. Since this is a roads layer, we will have 2 basic attributes - Name and Class. 
Enter Nameas the Name of the attribute in the New attribute section and click Add to attribute 
list. 
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9. Similarly create a new attribute Class of the type Text data. Click OK. 
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10. Once the layer is loaded, click the Toggle Editing button to put the layer in editing mode. 
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11. Click the Add feature button. Click on the map canvas to add a new vertex. Add new vertices 
along the road feature. Once you have digitized a road segment, right-click to end the 
feature. 

Note 
You can use the scroll wheel of the mouse to zoom in or out while digitizing. You can also hold the 
scroll button and move the mouse to pan around. 
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12. After you right-click to end the feature, you will get a pop-up dialog called Attributes. Here 
you can enter attributes of the newly created feature. Since the pkuid is an auto-
incrementing field, you will not be able to enter a value manually. Leave it blank and enter 
the road name as it appears on the topo map. Optionally, assign a Road Class value as well. 
Click OK. 
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13. The default style of the new line layer is a thin line. Let’s change it so we can better see the 
digitized features on the canvas. Right click the Roads layer and select Properties. 
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14. Select the Style tab in the Layer Properties dialog. Choose a thicker line style such 
as Primary from the predefined styles. Click OK. 
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15. Now you will see the digitized road feature clearly. Click Save Layer Edits to commit the new 
feature to disk. 
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16. Before we digitize remaining roads, it is important to update some other settings that are 
important to create an error free layer. Go to Settings ‣ Snapping Options... . 
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17. In the Snapping Options dialog, check the Enable topological editing. This option will ensure 
that the common boundaries are maintained correctly in polygon layers. Also check 
the Enable snapping on intersection which allows you to snap on an intersection of a 
background layer. 
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18. Now you can click Add feature button and digitize other roads around the park. Make sure to 
click Save Edits after you add a new feaure to save your work. A useful tool to help you with 
digitizing is the Node Tool. Click the Node Tool button. 

 

19. Once the node tool is activated, click on any feature to show the vertices. Click on any 
vertex to select it. The vertex will change the color once it is selected. Now you can click and 
drag your mouse to move the vertex. This is useful when you want to make adjustments 
after the feature is created. You can also delete a selected vertex by clicking the Delete key. 
(Option+Delete on a mac) 
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20. Once you have finished digitizing all the roads, click the Toggle Editing button. 
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21. Now we will create a polygon layer representing the park boundaries. Go to Layer ‣ New ‣  
New Spatialite Layer.... Select the nztopo.sqlite database from the dropdown list. Name 
the new layer as Parks. Select Polygon as the Type. Create a new attribute called Name. 
Click OK. 
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22. Click the Add feature button and click on the map canvas to add a polygon vertex. Digitize 
the polygon representing the park. Make sure you snap to the roads vertices so there are no 
gaps between the park polygons and road lines. Right-click to finish the polygon. 
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23. Enter the park name in the Attributes pop-up. 
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24. Polygon layers offer another very useful setting called Avoid intersections of new 
polygons. Go to Settings ‣ Snapping Options... . Check the box in the Avoid Int column in 
the row for the Parks layer. Click OK. 

 

25. Now click on Add feature to add a polygon. With the Avoid intersections of new 
polygons, you will be able quickly digitize a new polygon without worrying about snapping 
exactly to the neighboring polygons. 
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26. Right-click to finish the polygon and enter the attributes. Magically the new polygon is 
shrunk and snapped exactly to the boundary of the neighboring polygons! This is very useful 
when digitizing complex boundaries where you need not be very precise and still have 
topologically correct polygon. Click Toggle Editing to finish editing the Parks layer. 
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27. Now it is time to digitize a buildings layer. Create a new polygon layer named Buildings by 
going to Layer ‣ New ‣  New Spatialite Layer . 
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28. Once the Buildings layer is added, turn off the Parks and Roads layer so the base topo map 
is visible. Select the Buildingslayer and click Toggle Editing. 
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29. Digitizing buildings can be a cumbersome task. Also it is difficult to add vertices manually so 
that the edges are perpendicular and form a rectangle. We will use a plugin 
called Rectangles Ovals Digitizing to help with this task. See Using Plugins to see how to 
search and install plugins. Once the Rectangles Ovals Digitizing plugin is installed, you 
will see a new toolbar appear above the canvas. 

http://www.qgistutorials.com/en/docs/using_plugins.html
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30. Zoom to an area with the buildings and click Rectangle by Extent button. Click and drag the 
mouse to draw a perfect rectangle. Similarly, add remaining buildings. 



Project “Integrated planning and practices for mangrove management associated  
with agriculture and aquaculture in Myanmar - 2017P1-MYR” 

174 
 

 

31. You will notice that some buildings are not vertical. We will need to draw a rectangle at an 
angle to match the building footprint. Click the Rectangle from center. 
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32. Click at the center of the building and drag the mouse to draw a vertical rectangle. 
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33. We need to rotate this rectangle to match the image on the topo map. The rotate tool is 
available in the Advanced Digitizingtoolbar. Right-click on an empty area on the toolbar 
section and enable the Advanced Digitizing toolbar. 
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34. Click the Rotate Feature(s) button. 
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35. Use the Select Single feature tool to select the polygon that you want to rotate. Once 
the Rotate Feature(s) tool is activated, you will see crosshairs at the center of the polygon. 
Click exactly on that crosshairs and drag the mouse while holding the left-click button. A 
preview of the rotated feature will appear. Let go of the mouse button when the polygon 
aligns with the building footprint. 
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36. Save the layer edits and click Toggle Editing once you finish digitizing all buildings. You can 
drag the layers to change their order of appearance. 
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37. The digitizing task is now complete. You can play with the styling and labelling options in 
layer properties to create a nice looking map from the data you created. 
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10 Working with satellite image 
10.1 Overview of the task 
You will download free satellite image data from internet and conduct basic image processing in QGIS 
such as making colour composite with different band combination, implement image enhancement.  

10.2 Other skill you will learn 
- Clipping image to the area of interest and export image to different format. 

10.3 Get the data 
The USGS Earth Explorer provide access to many source of free satellite imagery. In this tutorial, we will 
use Sentinel image. 

Go to the Earth Explorer Website to download the data: https://earthexplorer.usgs.gov/ 

Alternatively you can use the image provided in the tutorial package under folder/Satellite image/ 

1. Define your area of interest 

 

2. In the dataset, chose Sentinel 2 image 

https://earthexplorer.usgs.gov/
https://earthexplorer.usgs.gov/
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3. In the Additional criteria tab select 20% cloud cover 

 

4. Click on the Result tab to view the search result. You can use the tool bar under each image to 
view the foot print, preview the image or download the image. 
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10.4 Procedure 

10.4.1 Loading image into QGIS 

1. Select the toolbar Add Raster (bellow Add Vector) and browse to the folder that contain the 
image. Select image B04, B03, B02 to open. Band 04 is captured in the Red wavelength or Red 
band; Band 03 is captured in Green Wavelength or green band; Band 02 is captured in Blue wave 
length or Blue band. 

 

The 3 band is added to the QGIS canvas 
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2. Each image band is displayed in grey scale. Use pan and zoom to examine the image. 

10.4.2 Create a virtual raster 

3. Create a virtual raster to stack 3 bands together so that we can make a colour composite image. 
Chose menu Raster/Miscellaneous/ Build Virtual Raster. 
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Chose Input File and select band 4,3,2. Name the output file Sentinel_432. The virtual raster is loaded into 
Layer Control.  

 

4. Right click on the Sentinel_432 and chose properties.  Increase Contrast to 10% and Saturation to 
10%. Click apply 
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10.4.3 Clipping image 

5. Clipping: Select Raster/Extraction/Clipper 

 

Chose Sentinel_432 as the input. Use Clipping mode Extend and daw the area of interest on the map 
canvas. Alternatively, you can choose to clip using a polygon defined by a vector file. 
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The clipped image is added to the map canvas 

 

 

 

10.4.4 Viewing image pixel value 

1. Use the Information tool to click on a vegetated area. This will display a dialog with pixel value 
from each band. 
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2. In the order of Band1 for Red, Band2 for Green, Band3 for Blue, you can see that the vegetated 
area have low value in Red (684) and high Value in both Green (1073) and Blue band (1067). 

Noted that combination of small amount of Red with large amount of blue and green is a greenness 
color. You can try some combination at http://trycolors.com/ 

Try to examine pixel value for other land cover such as water, bare land. 

 

 

http://trycolors.com/
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11 Image classification for land use/ land cover 
11.1 Overview of the task 
You will use the Semi-Automatic Classification Plug-in (SCP) in QGIS for image classification. The end result 
of image classification is the map, in this case land cover map. 

11.2 Other skill you will learn 
- Formulating suitable classification schema. 
- How to select effective training sample. 
- Accuracy assessment 
- Fine tune your classification result in GIS 
- Post classification processing 

11.3 Get the data 
We will use the same image that has been downloaded in Section 10. Working with satellite image. But 
this time we will use the reflectance data instead of the raw data. Reflectance image is the image that has 
been converted from raw DN number to reflectance value. Reflectance value is running from 0 to 1, with 
0 representing survey with almost no reflectance (deep lake for example) to survey that are very bright 
and reflect most of the incoming light (a solar panel for example). 

The data is located in the folder /SateliteImage/S2_Refletance/ 

11.4 Procedure 

11.4.1 Install or Enable SCP plugin 

In QGIS goto Plugins/Manage Install Plugin; search for semi-automatic classification. 

Enable the plugin or Install the plugin as required. 
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Once install successfully you should see a new tool bar and a menu for SCP in QGIS. 

 

11.4.2 Loading Sentinel image into QGIS 

Go to the Menu/SCP/Band Set, or you can choose the 1st icon on the SCP tool bar. 

Click on the Open File icon 



Project “Integrated planning and practices for mangrove management associated  
with agriculture and aquaculture in Myanmar - 2017P1-MYR” 

192 
 

 

Chose the folder /SateliteImage/S2_Refletance/Clip/ 

Open the file S2_Refletence.tif 

On the Quick View Wave lengh setting, select Sentinel 2. This is to enable QGIS to know which band belong 
to which wave length. 
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11.5 Classification 

11.5.1 Create region of interest (ROI) 

In the SCP Input window open the clipped image, start to select training sample for different classes. 

 

Create a ROI file to save the training sample. 
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Give the training sample a file name: Training 

 

In this tutorial we will use following classes: 

No. Group types Sentinel image 

1 Water 1 

 

2 Water 2 
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3 Water 3 

 

4 Paddy 1 

 

5 Paddy 2 

 

6 Resident 1 

 

7 Resident 2 

 

8 Bare soil 1 

 

9 Bare soil 2 

 

10 Road 1 

 

11 Road 2 
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12 Shrub Shrub 1 

 

13 Shrub 2 

 

14 Forest 1 

 

15 Forest 2 

 

 

To select the training sample on the image we use the Classification dock 
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Use the select ROI tool    to draw the training area. 

 

Select sample for water, the black area on natural colour image, give it the name Water 1 
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Draw a sample Water2 for the river. 

 

Draw water 3 for river with different colour. This is to make sure that all the water with different colour 
will be considered during the classification process. 
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After selecting enough sample for water we will see that MC ID is the ID for all class water; the C ID is the 
sub-class used to identify different type of water. 

 

Select sample for paddy rice, we need to increase the MC ID to 2, this is the broad group ID for paddy. 

 

Select sample for Paddy 2. 

Keep selecting sample for all classes in the area. 

After select all the sample needed, we change the colour to match the class. You can use any colour, but 
try to use some colour that easy to recognize. 
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11.5.2 Run the classification 

Before running the classification for the whole area, we can use the Preview Classification tool to preview 
the classification result of a small area. 

Click on the Preview button , and then click to any are on the image. This will make a quick 
classification of a small area so that you can review if the classification make sense. If you are not satisfying 
with the result, this is the time to revise your training sample: delete some sample, select some more 
sample, adding new classes. 
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Click on the Classification algorithm to run the classification: 

 

In the  “Classification output” give it a file name 
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The result of the classification is a Shape file and a Tiff file. 

 

11.5.3 Post classification 

The result of the classification can have many small pixels that make the output like salt-and-pepper. To 
reduce this salt-and-pepper effect, use use the Sieve tool to remove this. 

In the menu bar chose SCP/Postprocessing/Classification Sieve 
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After remove the noise, the isolated pixel will be merged to neighbour class 

 

After remove the noise, we need to export the result to vector for further processing. Use menu 
CSP/Postprocessing/Classification to vector 
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Chose the file name of the final classification to be converted to vector. 

 

11.5.4 Accuracy assessment 

Before conduction accuracy assessment we need conduct the reclassification to combine sub-classes into 
single class (remember we have water 1, water 2, water 3) 

Go to Menu/SCP/Postprocessing/Reclassification 
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Change the old class value to new class value, so that we come from 15 sub classes to only 7 classes 

 

Open the sampling point file, which is an independent ground truth set: Sampling_points_ras 
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The accuracy of the classification is calculated and display. The overall accuracy is 76.5% 

 

 

 

For further understanding of the accuracy assessment concepnt see following material 

http://web.pdx.edu/~nauna/resources/9-accuracyassessment.pdf 

http://www.utsa.edu/lrsg/teaching/ees5083/l9-classaccuracy.pdf 

 

 

http://web.pdx.edu/%7Enauna/resources/9-accuracyassessment.pdf
http://www.utsa.edu/lrsg/teaching/ees5083/l9-classaccuracy.pdf
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